от
У меня проблемы с установкой Docker на дистрибутив CentOS. Я следил за официальной документацией, но на этом этапе я получаю следующую ошибку:
$ sudo yum install docker

И ошибка:


  Ошибка: Пакет: containerd.io-1.2.6-3.3.el7.x86_64 (docker-ce-stable)
  
  Требуется: container-selinux> = 2: 2.74
  
  Ошибка: Пакет: 3: docker-ce-18.09.7-3.el7.x86_64 (docker-ce-stable)
  
  Требуется: container-selinux> = 2.9
  
  Вы можете попробовать использовать --skip-broken, чтобы обойти проблему
  
  Вы можете попробовать запустить: rpm -Va --nofiles --nodigest


После других сообщений в StackOverflow я попытался добавить репозиторий «extras» (хотя он должен был быть включен по умолчанию). Я использую sudo yum, но даже после этого sudo yum repolist
не перечисляет его. Вместо этого у меня есть
Local Repository
(я не очень хорошо знаком с CentOS, поэтому не знаю, нормально ли это). Я также попытался добавить отсутствующий пакет вручную:
wget http://mirror.centos.org/centos/7/extras/x86_64/Packages/container

Это возвращает отсутствующие собственные зависимости:

Error: Package: libsemanage

Но попробуйте вручную установить любой из этих возвратов, например:

Package matching libsemanage

У кого-то были похожие проблемы?
    

        

Ваш ответ

Отображаемое имя (по желанию):
Конфиденциальность: Ваш электронный адрес будет использоваться только для отправки уведомлений.
Анти-спам проверка:
Чтобы избежать проверки в будущем, пожалуйста войдите или зарегистрируйтесь.
...