от
Я пытаюсь установить QT4 (32 бита) на Ubuntu VirtualBox (64 бита). Я борюсь с установкой из-за ошибки ssl, от которой я не могу избавиться ... Вот что я сделал: Я скачал архив qt -where-opensource-4.8.7.tar.gz Я извлек это Внутри папки я набираю эту команду:
./configure 


Затем я набираю make
, но у меня есть ошибка:
Makefile:18201: recipe for target '.obj/debug

Вот пакеты, которые у меня есть, которые могут быть интересны:



Я знаю, что эта проблема может быть связана с версией libssl, но я пытался установить более старую версию, 64 или 32 бита, но у меня все еще есть эта ошибка ...

Я был бы очень признателен за помощь в этом!

Спасибо !
    

        

Пожалуйста, войдите или зарегистрируйтесь для публикации ответа на этот вопрос.

1 Ответ

0 голосов
от
Я нашел решение! Проблема возникла не из-за
libsll
, но она была связана с версией
openssl
. Версия 1.1.1 была установлена (как мы видим на первом экране). Поэтому я переименовал исполняемый файл
/usr/bin/openssl
в
/usr/bin/openssl.1.1.1
и установил более старую версию openssl (1.0.2):
wget https://www.openssl.org/source/openssl

И это все ! Я проверил версию, набрав openssl version
, и она вернула
1.0.2
! Тогда QT4 скомпилирован просто отлично!     
...